Sign in   |  Join   |  Help

Help needed on a flickering screen

rated by 0 users
Not Answered This post has 0 verified answers | 7 Replies | 1 Follower

erandlux
Top 500 Contributor
113 Posts
OFFLINE
Bronze Member
erandlux posted on Mon, Sep 15 2014 1:51 PM
Hello guys,

I am still strugeling with my beovision 7.

Could you please have a look for those who have some time on the following video.

http://youtu.be/ZJn5MP3Xjus

The screen is flickering with vertical white lines, when watching to HD or full HD sources ( bluray, mkv files,....) from different sources (OPPO, setop box, ). It happens the first 30 minutes. No problem with non HD content so far.

My dealer is really concerned about it, he changed 2 times the central unit of the BV, we send the log to B&O, but all our trial did not change the problem.

If you have any ideas on the possible source of this, please let me know (HDMI cables are new and top quality, I tested with different ones, and still flickering)

Thanks for your help

Best regards,

Eric

All Replies

Raeuber
Top 50 Contributor
Germany
2,542 Posts
OFFLINE
Bronze Member
Hello Eric,

please tell me first: Is it a BV 7-40? Which Mk is your BV 7, Mk 6? Year of production? First two items of serial number? Did flickering appear from the beginning of ownership?

Regards

Räuber
erandlux
Top 500 Contributor
113 Posts
OFFLINE
Bronze Member
Hi,

It is a 7-40 MK6 model with 3D, without bluray. I am not at home , but I can provide the serial if needed.

I bougt it less than 2 years ago.

The flickering was there after a few month, but first you think it is the source, not the brand new TV, and after multiple testing, you come to the conclusion that it is the TV.
Raeuber
Top 50 Contributor
Germany
2,542 Posts
OFFLINE
Bronze Member
Hi Eric,

I bought my BV 7-40 Mk 6 at the end of 2011 and I had exactly the same problem, I could send you a video that shows exactly these vertical flickering stripes as on your screen! The problem existed from the beginning and appeared also during warmup about 30 minutes after switch on the tv. Sometimes it also appeared with SD sources and even with analogue tuner of BV 7, but very seldom. During the time the problem appeared more and more often. Watching football world championship this summer was no fun at all.

I had very much trouble with my dealer. His technican tried to repair BV 7 four times without any success. He replaced the panel two times, the PIM module also 2 times; in June nearly everything was replaced, repair took 7 hours! All without any success! B&O in Germany also didn't know what to do. Therefore I demanded a replacement of the whole TV, but as you know BV 7-40 is out of production. But I was happy to find a BV 7-40 Mk 6 in a store of another dealer. It was produced also in 2011 or 2012 and was in a mint condition with only a few hours of operation. Two weeks ago my faulty BV 7-40 was replaced with this one and it works without any problems. I hope the flickering screen will not appear again in the future.

The faulty BV 7 was send to Struer for further investigations.

Greets

Räuber
erandlux
Top 500 Contributor
113 Posts
OFFLINE
Bronze Member

Thanks a lot,

 

I will have a look with my dealer, and see what he can do.  I send you a PM.

 

 

Best regards

 

 

Eric

bootneckbandy
Not Ranked
4 Posts
OFFLINE
Bronze Member

Eric

i am now on my 6th BeoVision 7, and on my second latest blu ray 3d version. Last year I had the flickering lines down the tv, it took ages for B&O to inverting ate and sent an engineer from Denmark. Despite lots of head scratching, they were unable to cure it, so replaced the tv with another tv, in fact it was next on the production line. Despite my concerns I accepted it. Low and behold the screen flickers returned, although an earlier lower spec loan set did not produce the problems. This new tv has had the HDMI board replace, the pin board replaced and a new screen.

although the flicker has change position, it is still there. I will be contacting B&O uk tomorrow as they. Are again dragging there feet. This is not the only issue I have come across regarding the screen flickering. I will update as and when I get a solution.

 

paul 

mayface
Not Ranked
36 Posts
OFFLINE
Bronze Member

It's the power supply that causes this. It took us and B&O a little over a year to find this out. 

Raeuber
Top 50 Contributor
Germany
2,542 Posts
OFFLINE
Bronze Member
mayface:

It's the power supply that causes this. It took us and B&O a little over a year to find this out.

Hello mayface,

this makes sense because the power supply was the only part in my faulty BV 7-40 Mk6 that was NOT replaced.

Regards

Räuber
Page 1 of 1 (8 items) | RSS
Beoworld Security Certificate

SSL