Sign in   |  Join   |  Help

CDX woes

rated by 0 users
Answered (Verified) This post has 1 verified answer | 53 Replies | 3 Followers

sonavor
Top 50 Contributor
Texas, United States
3,330 Posts
OFFLINE
Gold Member
sonavor posted on Tue, Aug 19 2014 11:38 PM

Back in 2012 on the old workbench forum, I (kind of) got my first CDX working. The unit required the door hinge fix on the eject switch side and I was able to get the CD player working for a short while. Then it started acting up (working intermittently). Resolving that it was an alignment problem with the hinge switches, I put the CDX up and worked on other projects.

Later, I received a second CDX that had good hinges.

I spent the last week trying to get one good functioning CDX out of the two. I actually had the unit playing CDs for one night. The next morning, it wasn't working again.

So far, I have resoldered the griplets on the two main boards of the first CDX.  The second CDX looks to be a later version and has nicer looking griplets. For now I haven't touched those.

The problem I am having right now is the CD motor spins all of the time. When the lid is open, I checked all of the switches and they measure as expected. Yet the motor spins. Two days ago the CDX unit started functioning correctly.  I could turn power on, open the lid, observe the motor wasn't spinning, insert a CD, hit play and the unit would start right up. It sounded really good when it works. The next morning I turned the unit on, inserted another CD and was surprised the the motor was already spinning the platter. So it broke overnight. 

So at various times I have seen both of my CDX main chassis operate correctly while, right now, they both behave the same and will not stop turning.

That makes me suspect the problem is common to both so it would have to be in the common pieces of my latest tests...which are the lid components: eject assembly, lid door motor assembly and control panel assembly. The only thing is - I have seen it work with those same components. Maybe a loose wire somewhere?

As I said earlier, the two switches on the door open motor assembly and the one switch on the door eject assembly appear to be operating correctly. I can measure continuity and open on the switches as the door hinges go through their travel.

Answered (Verified) Verified Answer

sonavor
Top 50 Contributor
Texas, United States
3,330 Posts
OFFLINE
Gold Member
Verified by sonavor

Okay Jacques and Martin....Apparently, the griplet re-soldering fixed the CDX. I did just the servo board first, it didn't fix the problem.  Next I did the Decoder board. When I reconnected everything, there it was - the motor powers on stopped. The stopped voltage was less that a volt.  I put the cover back on and tried a CD. The CD played.

This is a goofy piece of audio equipment for sure. I wish I had just soldered one griplet then tested before I moved to the next one. It would have been nice to know which part of the circuit was actually causing the problem.

Another strange thing was that I have two CDX units that fail in the same way (motor wouldn't stop spinning), yet the problem must be two separate issues with the main assembly. I thought that was not a likely scenario and the problem must be something common to both. That theory started falling apart when the problem remained regardless of what lid I used.

So I still have the second (CDX 001 in my earlier references) unit that I will put away for now until I get a door motor gear for it. On that unit I had already reworked the griplets but I guess I will have to retry that again. Of course there could be an actual failed component on the unit...but it had worked as recently as last week.

I will see if this working unit (CDX 002) continues to work tomorrow.

All Replies

opirat
Not Ranked
6 Posts
OFFLINE
Bronze Member
opirat replied on Fri, May 22 2020 5:14 PM

Hi, could you please give me Jacques contact. I have the same problem with my beogram cd 3300, maybe I can get a new gear. Thanks, have a good day/night, Luigi

sonavor
Top 50 Contributor
Texas, United States
3,330 Posts
OFFLINE
Gold Member

Hi Luigi,

Check out this more recent thread where some other people are working on replacement gears.

-sonavor

chartz
Top 25 Contributor
Burgundy, France
3,942 Posts
OFFLINE
Gold Member
chartz replied on Sun, May 24 2020 2:55 PM

Hi Luigi,

Still around, but this was a one-off!

Best wishes!

Jacques

chartz
Top 25 Contributor
Burgundy, France
3,942 Posts
OFFLINE
Gold Member
chartz replied on Sun, May 24 2020 2:55 PM

No, nothing. Big Smile

Jacques

chartz
Top 25 Contributor
Burgundy, France
3,942 Posts
OFFLINE
Gold Member
chartz replied on Sun, May 24 2020 2:55 PM

Hi Luigi,

Still around, but this was a one-off!

Best wishes!

Jacques

opirat
Not Ranked
6 Posts
OFFLINE
Bronze Member
opirat replied on Sun, May 24 2020 6:40 PM

Thanks sonavor!

opirat
Not Ranked
6 Posts
OFFLINE
Bronze Member
opirat replied on Sun, May 24 2020 6:40 PM

Thanks sonavor!

opirat
Not Ranked
6 Posts
OFFLINE
Bronze Member
opirat replied on Sun, May 24 2020 6:41 PM

Thanks you all guys! All the best!

Majlanky
Not Ranked
5 Posts
OFFLINE
Bronze Member
Majlanky replied on Fri, Jul 31 2020 10:12 PM

Hello everybody.

I have troubles with my CD X. I have read all topics here on the forum about CD X and its issues. I get my CD X many year ago as present in non-functional state. For many years I have been thinking the CDM fails. Last week I bought another CDM from eBay, change it and no change happen. Now I know it was pretty stupid move but it kicked me into fixing it. 

  1. The original issue was ? on display after pressing play. Motor was spinning few seconds and ? appeared.
  2. I changed CDM
  3. Same issue ad point 1
  4. I fixed all rivets/griplets (resolder it with copper wire pushed thru) on decoder and servo board
  5. After the rivet fix, there were strange issue with motor not stop spinning even lid open. I let it be for one day and the strange issue not appear anymore.
  6. The original issue is back/still here
  7. I checked pin14 connection with griplet as described in this topic

I am not good in electronic but I do not want to resing. 

Do you have any idea, what i can/should do next?

Thank you very much!

Page 4 of 4 (54 items) < Previous 1 2 3 4 | RSS
Beoworld Security Certificate

SSL