Sign in   |  Join   |  Help
Click here to tell us about your new email address

Browse Forum Posts by Tags

Showing related tags and posts for the The Workbench forum. See all tags in the site
  • Mute relay suggestions

    Hi everyone! I have a Beomaster 5500 with a shot mute relay. I also have a couple of similar units that probably will need the relay replaced sometime soon. Now, my question is whether someone has had good or bad experiences with any particular make or kind of that type of relay? If there's a particularly...
    Posted to The Workbench (Forum) by Johan on Tue, Aug 28 2012
    Filed under: beomaster 5500, mute relay
  • Beomaster 5500 tuner misbehavior

    I made the mistake of unplugging my BM5500 to dust behind it a while ago, and it hasn't quite been the same since. When I reconnected it, the sound settings had gone nuts (bass and treble turned way down, balance all the way over to one side), and my tuner presets were gone, replaced by all sorts...
    Posted to The Workbench (Forum) by halkyardo on Sat, Dec 22 2012
    Filed under: beomaster 5500, tuner
  • Beomaster 5500 initial volume problems

    Hello all I am new to this forum and hope for your help on my (new old) Beomaster 5500. When I turn on the system the sound is very low with a lot of treble and no bass. I can get the sound back into normal quality by increasing or decreasing the volume on the master control panel – it makes some...
    Posted to The Workbench (Forum) by Jeruan on Thu, Dec 27 2012
    Filed under: beomaster 5500
  • Beomaster 5500 T4a fuse blows every time power is connected

    hi ... I have no electrical engineering knowledge... i have a multimeter but v.little idea how to use it.. so now you know what your up against! Therapeutic as it is watching the fuse blow i figured it wasn't worth sacrificing a 3rd one to watch it go up in an orange flash.... so i need help understanding...
    Posted to The Workbench (Forum) by dan1969 on Sat, Apr 27 2013
    Filed under: beomaster 5500, internal fuse, blown, fuses, dillen beomaster 5500 t4a fuse
  • Beomaster 5500 - No Aux_Tape2 RH Channel

    Hello, Decided to get to the bottom of a problem with an old 'E-Bay' purchase - perhaps someone can assist. MCP 5500 seems to work fine - can audibly hear the Mute Relay cycle. No audio output from RH speaker (either 1 or 2) when using Tape2/Aux RCA Jacks - However, both L & R channels work...
    Posted to The Workbench (Forum) by rgauci on Sun, Feb 15 2015
    Filed under: beomaster 5500
  • Beomaster 5500 starts spontaneous

    Hello fellow B&O lovers, I have a strange problem. My beomaster 5500 sometimes starts without my doing. It' looks like there is a tiny DJ inside my equipment ;). It is always random. Can anyone direct me for a solution?
    Posted to The Workbench (Forum) by flipper62 on Thu, Feb 9 2017
    Filed under: beomaster 5500
Page 1 of 1 (6 items)