Sign in   |  Join   |  Help
Click here to tell us about your new email address

Browse Forum Posts by Tags

Showing related tags and posts for the BeoGram forum. See all tags in the site
  • Re: Beogram 5500 won't turn on

    Hi Menahem Just saw your response re. tangential-tracking arm issue on Beogram 5500. In my case, the Play function works, the arm goes up and down and plays the record properly. However, the cartridge does not slide anymore, ultimately leading the reading to stop. I am kind of scared to carry out your...
    Posted to BeoGram (Forum) by pfroche on Thu, Jun 27 2013
    Filed under: tonearm, Beogram 5500, tangential, tangential arm issues, Beogram 5500
  • Beogram 5500 (any 594x)

    Hi Just cant see where is problem. BG is making ratling noise at begining of arm return aslever X is ratling against tables center axis. Why?? Cant see any adjustments, everthing is clean and nice, belt are new... Cant (?) be on electronics board as I tried two. Neither I did noit see any difference...
    Posted to BeoGram (Forum) by Orava on Mon, Jan 5 2015
    Filed under: Beogram 5500, beogram, 549X, 6500, 4500
  • Beogram 5005 Arm Not Lifting / Strange Behavior

    Hello fellow beoworlders! I am looking for some help regarding my new system, and this seems like the most appropriate section to post it. The post on my new Beosystem 5000 can be read here . I am having mixed luck in getting the Beogram to operate correctly. I am aware that the stylus is past its best...
    Posted to BeoGram (Forum) by Lewis on Mon, Apr 25 2016
    Filed under: Beogram 5005, Beogram 5500, tangential, beogram, beomaster, tangential arm issues, mmc4, mmc 4
  • A Beogram 5500 gone mad?

    Hello everybody, I have a Beogram 5500 purchased and it worked well for about 10 minutes. Now it still turns and moves, but it does not correctly reacts to the push of the buttons. Any idea of what is happening? be seeing you François
    Posted to BeoGram (Forum) by Francois1er on Tue, May 8 2012
    Filed under: Beogram 5500
  • Re: Beogram 5500 stopped mid-play, tonearm also stuck.

    As of today, my Beogram 5500 has exactly the same problem. I was wondering if there is already a solution to the problem? Thanks, Job
    Posted to BeoGram (Forum) by jozo on Wed, Jan 16 2013
    Filed under: tonearm, problem, Beogram 5500, tangential
Page 1 of 1 (5 items)