Sign in   |  Join   |  Help
Click here to tell us about your new email address

Browse Forum Posts by Tags

Showing related tags and posts for the The Workbench forum. See all tags in the site
  • Beocenter 8000 no radio

    Hi Guys Hoping you may be able to help out with this problem. Recently I purchased said item with known fault that tape didnt work and door jammed in open position and the inevitable rebonding of glass panels these are now resolved after a total strip and I mean a total strip and clean internally all...
    Posted to The Workbench (Forum) by Maurice on Wed, Apr 11 2012
    Filed under: Beocenter
  • Thinking of parting out Beocenter 9000 & 9500

    Somehow I have ended up with two Beocenter 9000's and a 9500 in various conditions. Since I only use one 9000 as a glorified clock radio, I'm thinking of parting out the other two, as currently they're only taking up space and it would be a shame to just stash them in the attic or throw them...
    Posted to The Workbench (Forum) by Zottenhond on Mon, Jun 18 2012
    Filed under: Beocenter, beocenter 9000 glass panels
  • Problem with door cords on a Beocenter 9500 (also applies to 9000 and 9300)

    I just got a used 9500 and I'm getting it back in operation. I have cleaned the tracks for the sliders and lubricated all of the moving parts with silicone spray. The tape door had an issue where the cord would wind over itself, and after some fiddling it starting rolling on and off the brass spindle...
    Posted to The Workbench (Forum) by Gregg on Tue, Jul 24 2012
    Filed under: Beocenter
  • BeoSystem3 not communicating with BeoVision4

    Hi, My problem s that I am not able to switch on TV and don't know if I have a fault or not. I have hooked up the Beosystem 3 to a Beovision 4 65" Plamsa (by Panasonic). When powering up the Beosystem, a green LED on the Beosystem is on for a couple of seconds and then switched OFF again. At...
    Posted to The Workbench (Forum) by alltvrepairs on Sat, Jan 19 2013
    Filed under: voltage, wiring, Beo4, Beocenter, photodiode, photocell, Repair
  • Beocenter 2800 - cant stop platter on record deck spinning

    Hi Everyone, Just wondering if anyone can help me, yesterday I got myself a Beocenter for a bargin! only £40 I have plugged it in and connected it to my Beovox s35-2's and I must say it sounds great. It is fully working apart from the odd sticky stitch what I believe is common and the issue...
    Posted to The Workbench (Forum) by Lewis T on Wed, Jan 1 2014
    Filed under: wiring, Beocenter, Vintage Beomaster, tonearm, beogram, Repair, amplifiers, power switch, on/off switch, fix, rebuild, turntable, vinyl, vintage
  • Beosystem 2500 question

    Hi I am new here and from the USA (please do not hold that against me). I have always wanted to get something from B&O and recently I had a chance at a Yard sale. I got a Beosystem 2500. It looks very interesting and sounds pretty nice but there are problems to sort out. I suspect it was stored in...
    Posted to The Workbench (Forum) by RalphARoni on Wed, Apr 9 2014
    Filed under: Beocenter, 2500, belt, cassette, Beosystem
  • BeoCentre 3500 Pick-up arm downstroke error

    Hello, I recently picked up a really good example of a white BeoCentre 3500 from a local charity shop for just a few pounds, and after re-foaming the woofer surrounds on the pair of 3702's that came with it, I now have a great sounding unit... with one niggle: The pick-up arm doesn't quite sit...
    Posted to The Workbench (Forum) by davehiskett on Thu, Oct 15 2015
    Filed under: Beocenter, tonearm, turntable
  • Beocenter 2200 with new amp.

    Hello. Due to the fact that the Beocenter 2200 isn't exactly the best in sound quality I bought a new amplifier to my system. The problem is that the 2200 is beautiful in it's design and I would still like to use the turntable. So to connect them I have used the headphone plug out connected to...
    Posted to The Workbench (Forum) by sirda on Mon, Nov 23 2015
    Filed under: Beocenter
  • Beocenter 7000 heating and shutting off issue

    Hello all, hope you're well today. Story : I purchased a Beocenter 7000 (type 1801) from a genlteman that had recently retired and was planning on leaving the country. He had purchased it back in '79-'80 and has had it stored away for almost 20 years if not more. I have been using an old...
    Posted to The Workbench (Forum) by CrabbyHermit on Mon, Feb 8 2016
    Filed under: Beocenter, Repair, vintage, Opamp, overheating, output, Beocenter 7000
Page 1 of 1 (9 items)