Sign in   |  Join   |  Help
Click here to tell us about your new email address

My Beolab Penta's (questions and restoration thread)

rated by 0 users
This post has 10 Replies | 1 Follower

Andrew
Not Ranked
Nicollet, MN
Posts 31
OFFLINE
Bronze Member
Andrew Posted: Fri, Feb 10 2017 8:15 PM

So I know I've been kind of all over the place here, but I'm really enjoying the Bang & Olufsen lifestyle and vintage products. So I took a plunge and bought a pair of Beolab Penta 1 speakers (6603). I knew they would have some of the usual issues. Rotted surrounds on the mids, and an amp supposedly has an issue as well.

My goal with this thread will be to document the repairs as best as I can, and also to ask questions of others who have done similar restorations. This pair of Penta's are far from perfect, so it will be a bit of a process for me, and I don't expect it to go too quickly.

A little background information first. I bought these from the original owner. He stated right away that one of the amps had an issue for sure, and he wasn't sure about the other since he was using them with a different amplifier all together. He also stated that he didn't know how to remove the grills, so he was unable to check the rot condition of the mid range drivers.

After unpacking everything, I checked to see what I all had. Speaker towers, check. Beolab 150 amps, check. Speaker stands, check. Hardware to secure them all together... Nope, dang. Oh well, that's pretty easy to find, but it would be nice to confirm the size of bolts that I need. I think according to the service manual, it's a 3.5 x 50mm (page 4-4).

So, after a few emails to Peter, talking about the speakers. I then sent an email to Martin asking about his amp and crossover refresh kit. He asked for a few pictures of the crossovers since there can be a few different styles. So I dug into the speakers, and found a mess! The crossovers have been worked on previously for sure since one board in each tower had tape over the sides, and some weren't even in the proper grooves inside the tower.

I also found coils that have fallen off the board. On one of the boards, the magnets that go around two of the coils were shattered and the pieces were laying inside the towers. This could have been due to shipping, but I'm now going to have to figure out what to do with them.

Notice the broken magnets around the coils here:

So my questions are as follows:

1) Do I need to replace the coils that have come loose? Or do I just re glue them to the board?

2) Are there replacement coils for the ones with the broken magnets?

3) Should I go with the foam surrounds? Or the rubber ones?

4) Any ideas on how to un crush the dust caps on the woofers?

Andrew
Not Ranked
Nicollet, MN
Posts 31
OFFLINE
Bronze Member
Andrew replied on Sun, Feb 19 2017 5:43 PM

So after a few emails to Martin, I've found that this is a very early model. Also, I was incorrect, the broken pieces of the crossover are not magnets.

So it looks like my best options are to find other sets of crossovers. Unless anyone knows how to get new parts for these?

priklep
Not Ranked
Slovakia
Posts 38
OFFLINE
Bronze Member
priklep replied on Mon, Feb 20 2017 9:00 AM

Hi Andrew,

ask Martin (Dillen) again.

priklep
Not Ranked
Slovakia
Posts 38
OFFLINE
Bronze Member
priklep replied on Mon, Feb 20 2017 9:00 AM

He probably could source parts for Penta's. He is located in DK.

Weebyx
Top 150 Contributor
Denmark
Posts 558
OFFLINE
Bronze Member
Weebyx replied on Mon, Feb 20 2017 10:06 AM

The hardware to secure the amplifiers and feet to the base, are much longer than 5cm...

You can see them here.

The first are secured to the speaker, then you slide the amp along it, and again under that, you attach the feet and secure the 3 parts with bolts.

http://www.ebay.ie/itm/5x-Bang-Olufsen-Beolab-Penta-Screws-Bolt-Rod-Threaded-/181511810408

Each penta needs 5 pieces.

I have used foam surrounds in the ones I have restored.

Regarding your loose coils, I would try to glue them back on, and the plastik bits that came of, true also with glue.

You can just connect both speakers to an external amp and run them as passive Pentas, just to see if they work.

I have uncrushed a cone just using a bit of sticky tape, press it "hard" where the crunch is, and then pull back quick, it solved it for me.

 

Andrew
Not Ranked
Nicollet, MN
Posts 31
OFFLINE
Bronze Member
Andrew replied on Mon, Feb 20 2017 1:51 PM

Weebyx:

The hardware to secure the amplifiers and feet to the base, are much longer than 5cm...

You can see them here.

The first are secured to the speaker, then you slide the amp along it, and again under that, you attach the feet and secure the 3 parts with bolts.

http://www.ebay.ie/itm/5x-Bang-Olufsen-Beolab-Penta-Screws-Bolt-Rod-Threaded-/181511810408

Each penta needs 5 pieces.

I have used foam surrounds in the ones I have restored.

Regarding your loose coils, I would try to glue them back on, and the plastik bits that came of, true also with glue.

You can just connect both speakers to an external amp and run them as passive Pentas, just to see if they work.

I have uncrushed a cone just using a bit of sticky tape, press it "hard" where the crunch is, and then pull back quick, it solved it for me.

 

Oh, this is very helpful. I did not know that the screws would be double side threaded rods. Very nice to find this out! Thank you for all the information, and I will try all these tips out. Though instead of buying the rods for $60.56 on eBay, I'll try to see if I can get them from a local fastener company. I'll just have to find out the proper length and thread size. The thread size will be easy since I have the nuts from inside the speaker cabinet. Length might be a little tricky.

 

Andrew
Not Ranked
Nicollet, MN
Posts 31
OFFLINE
Bronze Member
Andrew replied on Mon, Feb 20 2017 1:53 PM

priklep:

He probably could source parts for Penta's. He is located in DK.

Thank you! I have been in contact with him, and plan on purchasing the amp kit for sure.

riverstyx
Top 75 Contributor
Exeter, Devon, UK
Posts 884
OFFLINE
Gold Member
riverstyx replied on Fri, Feb 24 2017 10:45 PM

Andrew:
4) Any ideas on how to un crush the dust caps on the woofers?

I usually use a vacuum cleaner to pull them back out.

Andrew
Not Ranked
Nicollet, MN
Posts 31
OFFLINE
Bronze Member
Andrew replied on Fri, Feb 24 2017 11:01 PM

I did try my little shop vac, and it wasn't powerful enough. I'm scared to try my Dyson. I have watched a few YouTube vids on this subject and also the tape idea from earlier, so I'll look into those first.

 

GregKo
Not Ranked
NYC
Posts 20
OFFLINE
Gold Member
GregKo replied on Fri, Feb 24 2017 11:51 PM

Hi Andrew - I recently restored a set of Pentas (2's) and commend you for giving it a go.

 

Regarding the dust caps - It's pretty much a cosmetic issue that doesn't effect the sound, but in the pursuit of "perfection" there are a couple of options.

Obviously the right way to do it is to remove the cap and order and install new ones - I've done this and is by far less effort than reforming the midrange surrounds (that's a messy job).

 

For a quick fix, however, simply bend the tip of a long thin needle into a curved shape, pierce the dust cap (often in a few places) and carefully pull it back out.  That should work fine to restore them aesthetically and all you really need to do after that is fill the holes you made - A dap of contact cement, thick cyanoacrylate glue (superglue, crazy glue, etc.) will do the job.

Keep us posted on your progress!

 

Take care

 

Greg

 

Beocenter 9500, Beomaster 6500, Beolab Penta MKII, Beolab 5000, Beolab 3000, Beolab 4000 MKI, Beolab 4000 MKII, Beogram 3300, Beogram 3000, 2X Beolink 7000 RDS, 2X MCP 6500

Andrew
Not Ranked
Nicollet, MN
Posts 31
OFFLINE
Bronze Member
Andrew replied on Sun, Mar 12 2017 6:10 PM

So I was able to spend a little time on these yesterday. First I tried to use a Q-Tip and glue method to un-dent the dust caps, but I proved to not have the proper patience for it. I also tried the cardboard tube and suck method, but I proved to not have enough suction for that. I wanted to save the pin method as a last resort, because I knew it would leave a small hole, so I went back to the Shop Vac method. This time with a much bigger and more powerful Shop Vac. This worked! I had to use two fingers to steady the cone, while the vac sucked on the dust cap. It's not perfect, but it's MUCH better than it was.

I also can say that the B&O Type number is: 6603, even though I know that's not a huge thing, I just wanted to have that down in this thread for my own and others reference.

I spent a little time with the Ferrite Cores, I wanted to see if I could puzzle piece them together. I was unable to figure them out... but I'm still hopeful. Also, I've found that you can find similar items on Amazon. I'm wondering if this would be something worth while to look into? I'd sure love to get this part figured out so that I can continue on with the restoration.

Page 1 of 1 (11 items) | RSS