Sign in   |  Join   |  Help
Amazing choice of pre-owned Bang and Olufsen

Got a problem with the Forum?
then please email me at keith@beoworld.org with details

Click here to change your Beoworld Account Details

Beomaster 2400-2 left speaker channel failing

rated by 0 users
Not Answered This post has 0 verified answers | 2 Replies | 1 Follower

johnratso
Not Ranked
2 Posts
OFFLINE
Bronze Member
johnratso posted on Fri, Oct 27 2017 9:18 AM

Hi everyone.

This is my first post. one of both excitement and some challenge.

like many of you, i grew up in wonder of the beomaster 2400 and decided to relive that, by buying a good condition working 2400-2 beomaster with S50 speakers. I love it...

This unit has recently just has a capacitor replacement kit done throughout the main board. But recently the left channel has been inconsistently failing. I have moderate (hobby) level electronics fault/finding knowledge and sufficient tools, so am keen on solving this myself. That's part of the fun isn't it??

 

fault description:

Upon turning unit on, left speaker will be dramatically lower volume than right. With my ear close, i can hear the speaker working. First check,w as to move the balance slider back/forth, yet it works perfectly when this problem is not happening (no crackle or inconsistency)  and makes no difference to the fault when it is. I am ruling the balance out as a problem.

When failing, the left channel will be 95% quieter on both LF and LR. (RF and RR remain perfect). I have swapped speakers back/forth. the problem remains at the left channel/s output, which rules out the speaker, cables, connections etc.

I have then used both Line-In and FM channels to prove that the problem carries across any input source. Interestingly though. I have on a few occasions switched between FM and Line-In source and the channel has recovered at that change. Once recovered it seems to continue just fine until next power up of the unit. 

i took the back cover off and while it was cold, went around the PCB's just giving them a nudge/flex with the back of my driver to see if i could get any dry-joint noise in any area. no luck so far. I rechecked all the capacitor re-solders all looks OK. (BTW - i have not replaced the D50 Bridge Rec, but have been thinking to do it anyway)

when it does fail, or about to, i hear the volume in left channel become muddy, a little crackly or gravelly (if that makes sense) and then fades out to 95%+ gone.

my thoughts...

a) if it occasionally fixes itself when i switch between input source and then remains good, i am thinking a transistor or a cap is failing and presenting that line to switch. When moving between input sources it is just getting enough of a kick to fire up.

b) when working its clean and consistent. No noise from moving balance, treble, bass. So i feel not of concern.

c) the fact the main PCB is all re-capped and the output amp seems consistent. I am leaning towards starting to hunt around the pre-amp area

d) maybe a way to prove if pre-amp was a problem would be to hook up something to the phono and not use the line in. If Phono works perfectly, then its really points me to pre-amp / line-in area as a start (assuming that the FM tuner also produces line-level, so what i experience at external line-in could be also expected of its internal FM tuner)

Sorry for the long 1st post. but i thought i may as get down where i am up to... any advice would be greatly appreciated

John

All Replies

Dillen
Top 10 Contributor
Copenhagen / Denmark
9,627 Posts
OFFLINE
Founder
Moderator
Dillen replied on Fri, Oct 27 2017 10:24 AM

Could be a bad switching diode but most likely to be a bad balance potentiometer.
The small bronze contacts under the black sliding bridge breaks off and contact is lost.
A very faint sound is quite normal in these cases due to "overhearing".
A repair kit is available, containing new plastic bridge parts.

Martin

johnratso
Not Ranked
2 Posts
OFFLINE
Bronze Member

Thanks Dillen, 

your explanation makes sense. 

Is the fault something visual I could verify? I have no problems pulling the unit down and am just looking for guidance. Once in the right track, I would happily purchase the kit and replace a bulb on FM3 that is out at the same time.

 

Luke

 

Page 1 of 1 (3 items) | RSS