Sign in   |  Join   |  Help
Click here to change your Beoworld Account Details

Beoplay E8 Bluetooth issues

rated by 0 users
Answered (Verified) This post has 1 verified answer | 35 Replies | 2 Followers

Cardinalsong
Not Ranked
Melbourne, Au
21 Posts
OFFLINE
Bronze Member
Cardinalsong posted on Wed, Oct 11 2017 7:59 AM

Hi everyone,

Trying to work out if I’ve got bad luck or others are experiencing the same issues I am.

Picked up a brand new pair of E8 from my dealer that received their first delivery today. After charging them fully I took them for a spin. Noticed immediately the left hand bud would intermittently dip audio for half a second every 30sec or so.

took them for a walk and had continuous, sustained drop outs in both ears every few seconds, then fine for maybe 30sec, then more drop outs.

if anyone lived through the H8 launch in 2015, this feels very, very similar. I’m heartbroken as I really wanted the convenience of wireless buds, but the connectivity is atrocious.

using them with an iPhone 7 and an iPad Pro 10.5” left ear bud drop out in both, full dropping on the 7 only, especially when walking with the phone in my pocket. 

have attempted re-pairing and software updates, no success. 

Answered (Verified) Verified Answer

Submariner1
Not Ranked
1 Posts
OFFLINE
Bronze Member
Verified by Submariner1

Hello.I have been using these earphones for a couple of weeks,and i am happy with the sound quality,but not with the bluetooth conection.For some reason,if i turn my head to my left,i loose coonection,but when i face forward again,they connect.This is very annoying.Has anyone else had this problem.Thanks,Jihn.

All Replies

bloodscalper
Not Ranked
3 Posts
OFFLINE
Bronze Member

So far all my truly wireless buds (X1T, Bragi Headphones & Dash Pro, Beoplay E8) have a lag problem while using my Android (Samsung S8) phone. It's not really a pain but certainly noticeable. No problems while using them with iOS (Iphone SE). It's highly likely Apple's iOS is properly and successfully syncing the audio while playing videos.

bloodscalper
Not Ranked
3 Posts
OFFLINE
Bronze Member

Yup, same issue I have regarding finicky Bluetooth connections. Frequent dropouts while just turning my head to cross the road while phone is in my front right pocket. Gets worse when a light gust of wind blows my way. For each time the left bud 'pops' and loses connection for 1-2 secs, the music will then shift from center to the left. I needed to pause music, wait for 1-2 secs and resume to 'adjust' the sound back to center. These buds are strictly for indoor use only, coupled with your phone lying just next to you, and you best not make sudden movements or jerk away from your seat else you get another drop out.

But oy, the sound man....really makes it hard to return/refund them after sampling their sound for a few days. Just like being caught between a rock and a hard place.

 

harnham
Not Ranked
1 Posts
OFFLINE
Bronze Member

I've had the problem with the left earpiece on TWO sets now (first set replaced).  Never any problem with the right.  Both times I've updated the firmware to 5.4.0 but hasn't fixed the issue.  Just to clarify, I don't believe this is an issue with Bluetooth as such, but the way B&O transmit the signal to the left (slave) earpiece from the right (master).

bloodscalper
Not Ranked
3 Posts
OFFLINE
Bronze Member

I agree. I've also updated to 5.4 version yet to no avail. Both E8 & Bragi's buds use NFMI so how is it that the Dash Pro and Headphones have a much more solid connection compared to the E8? I think it's confirmed that my unit isn't the prob but rather the shoddy QC by B&O. Face it, the E8s suck no matter how much I love the sound.

adao
Not Ranked
1 Posts
OFFLINE
Bronze Member
adao replied on Wed, Jan 10 2018 11:03 PM

Does anyone have any fixes yet for this issue?

I unpaired and repaired my E8's which I thought it actually fixed it in the morning. But when i used it again on the commute home it was just dropping out again.

 

I'm gonna try contact B&O and the store i purchased from but not sure what they can do :( otherwise may have to return them

Submariner1
Not Ranked
1 Posts
OFFLINE
Bronze Member
Verified by Submariner1

Hello.I have been using these earphones for a couple of weeks,and i am happy with the sound quality,but not with the bluetooth conection.For some reason,if i turn my head to my left,i loose coonection,but when i face forward again,they connect.This is very annoying.Has anyone else had this problem.Thanks,Jihn.

Page 3 of 3 (36 items) < Previous 1 2 3 | RSS