Sign in   |  Join   |  Help
Click here to tell us about your new email address

Bv11 Nvidia Shield Netflix - no 5.1 audio

rated by 0 users
Not Answered This post has 0 verified answers | 27 Replies | 1 Follower

Marcello
Top 500 Contributor
134 Posts
OFFLINE
Bronze Member
Marcello posted on Tue, Mar 28 2017 11:46 AM

Hello, I was wondering if anyone has managed to output 5.1 audio from the Netflix app on the Shield. 

O matter what I try I get stereo only. Netflix says that the output device must support Dolby Digita plus for surround sound to be enabled but somehow it does not work. At some point I doubted the 11 supported DD+ so I removed the speaker grille and check the service label to confirm and it does indeed support the standard. 

Any tips? The net is full of similar complaints but none are related to B&O. 

Thanks in advance,

Marcello

All Replies

Michael
Top 50 Contributor
Sweden
1,873 Posts
OFFLINE
Bronze Member
So they didn't even put any effort into it. At the same time Nvidia is taking the issue seriously and are trying to replicate the issue on their end. They are also thinking the same that we are: that the EDID is the failure (which means B&Os fault).

The reason PS4 pro and Apple TV 4 works is because they decide DD+ internally.

At this moment my trust in B&O is lacking but at the same time their customer service department don't have the same capabilities as Nvidia but they should at least try harder. The response even after talking with someone in charge according to your message is just stunningly lame. Did you tell them anything else? The thing about EDID and so on? I can open a case with B&O as well but I guess it's easier for them to follow up one instead of two.
Marcello
Top 500 Contributor
134 Posts
OFFLINE
Bronze Member

Michael:
So they didn't even put any effort into it. At the same time Nvidia is taking the issue seriously and are trying to replicate the issue on their end. They are also thinking the same that we are: that the EDID is the failure (which means B&Os fault).

The reason PS4 pro and Apple TV 4 works is because they decide DD+ internally.

At this moment my trust in B&O is lacking but at the same time their customer service department don't have the same capabilities as Nvidia but they should at least try harder. The response even after talking with someone in charge according to your message is just stunningly lame. Did you tell them anything else? The thing about EDID and so on? I can open a case with B&O as well but I guess it's easier for them to follow up one instead of two.

I sent a gentle but firm response with some of the details I shared here and the CS representative thanked me for "elaborating" and told me she would forward it to the technical department. We'll see where it leads.

This could be solved either by a B&O Software Update (although my dealer today told me that the BeoSystem 4 is "old" and they are not focusing on it anymore..also adding that I'm lucky to have a BV11 and not one of the new Android TV-based sets - I won't mention the exact words but let's say he's not impressed and let's leave it at that), or by the addition of a switch in the Nvidia settings (Add "On" in addition to "Auto" and "Stereo") like the Fire TV has. But as you mentioned, if our findings are confirmed, it's B&O's who's at fault here.

If no one bothers to fix this, the only solution is to buy a device such as Dr HDMI from Hdfury to put in between the source and the TV to modify the EDID coming from the BV. The least I would expect from B&O is to send me such a device considering that I already spent 25 grand on the whole set and speakers.

Michael
Top 50 Contributor
Sweden
1,873 Posts
OFFLINE
Bronze Member
Nvidia replied that the EDID data indeed didn't contain tagging for EAC3. So the problem is 100% on B&O's behalf. They promise Dolby Digital Plus over HDMI and have to fix it otherwise I can even have my purchase revoked still in Sweden for five years after purchase and get the full amount back. I think B&O would prefer sending a firmware update that sets things right. Also, the bsys4 is far from dead. We are many owners and to keep new speakers working etc they need to push updates for us to be able to even use them properly. Everything else would also be a shame. Do you want me to also contact beocare or should we await their reply for you first?
Marcello
Top 500 Contributor
134 Posts
OFFLINE
Bronze Member

Yes please contact them, the more people reporting the same issue, the better chance we have that they do something about it, especially now that nvidia reached the same conclusion (likely with better credibility than my own investigation in the matter).

 

 

Michael
Top 50 Contributor
Sweden
1,873 Posts
OFFLINE
Bronze Member
I've done that now too. I hope they can fix it.
Michael
Top 50 Contributor
Sweden
1,873 Posts
OFFLINE
Bronze Member
They replied quick and I'm not sure they took my information or explanations. I hope they did and that they will evaluate it. We will see, after Easter I suppose.
Fl_ip
Top 500 Contributor
130 Posts
OFFLINE
Bronze Member
Fl_ip replied on Wed, Apr 12 2017 7:30 PM
Michael:

They replied quick and I'm not sure they took my information or explanations. I hope they did and that they will evaluate it. We will see, after Easter I suppose.

Got an Know Error number? Or a referance number then I could call them tomorrow
Michael
Top 50 Contributor
Sweden
1,873 Posts
OFFLINE
Bronze Member
Michael replied on Wed, Apr 12 2017 11:11 PM
No, just the notice that there is an issue open about it. I just sent a question to beocare. You can do that too if you also have the issue.
Fl_ip
Top 500 Contributor
130 Posts
OFFLINE
Bronze Member
Fl_ip replied on Thu, Apr 13 2017 6:32 AM
The number we could use is in the subject.

Something like: Incident: 170411-000XXX]
Michael
Top 50 Contributor
Sweden
1,873 Posts
OFFLINE
Bronze Member
Michael replied on Fri, May 19 2017 10:48 AM
Great news! B&O messaged me today and told me they found the same issue as we did, that he EDID data is missing for DD+. They are working on an updated software to fix it!

This is great news to all Nvidia Shield TV users who owns a Bsys4-based set (I guess the update won't be only for the Avant but I don't know). Smile
Marcello
Top 500 Contributor
134 Posts
OFFLINE
Bronze Member
Marcello replied on Fri, May 19 2017 12:16 PM

Great, I hope they don't leave behind us owners of the BV11. Two days ago they did not have any news about the issue. 

I guess I'm gonna send them another email today! 

Michael
Top 50 Contributor
Sweden
1,873 Posts
OFFLINE
Bronze Member
Marcello:

Great, I hope they don't leave behind us owners of the BV11. Two days ago they did not have any news about the issue.

I guess I'm gonna send them another email today!

It's also beosystem 4 based so it will probably get the same update! I got the news today, so that's probably why you haven't heard back!
Marcello
Top 500 Contributor
134 Posts
OFFLINE
Bronze Member

Slightly different wording in the reply to my question from today, where I mentioned that I was aware that a fix was in the works for the Avant...

 

"Our technicians have established that the EDID data in the TV does not include Dolby Digital Plus.

The request for this to be added has been forwarded to the R&D team, and I will let you know in case a correction to this is implemented"

Page 2 of 2 (28 items) < Previous 1 2 | RSS